Protime Premium and myProtime general issue

Incident Report for Protime

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 13:00 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2026 - 12:12 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 18, 2026 - 12:10 CEST

Investigating

We are currently investigating an issue affecting myProtime and Protime Premium .

Our teams are actively working to identify the root cause and resolve the issue as quickly as possible.

We are doing everything possible to keep disruption to a minimum.
Posted Aug 18, 2026 - 11:44 CEST
This incident affected: Protime Applications (ProTime, ProTeam, Export, Import, Yeartool, UserProvisioning) and myProtime (myProtime).